Introdução
No contexto de talhões agrícolas, polígonos com buracos podem representar um cenário incomum e frequentemente problemático. Os talhões agrícolas são tipicamente áreas contínuas e delimitadas de terras agrícolas. Lacunas dentro desses polígonos podem surgir de erros de dados, como limites desalinhados, digitalização incompleta ou conjuntos de dados sobrepostos.
Na maioria dos casos, não faz sentido que os talhões agrícolas tenham buracos, pois eles interrompem a representação da área útil e podem levar a problemas significativos na análise espacial. Essas questões incluem cálculos imprecisos do tamanho das parcelas, ineficiências nos modelos de alocação de recursos e erros na classificação do uso do solo.
Esta documentação explica como remover buracos de polígonos usando QGIS, um popular sistema de informação geográfica de código aberto. Se o QGIS ainda não estiver instalado na sua máquina, leia este recurso do QGIS para instalar o aplicativo.
Este tutorial foi feito usando um computador MacOS. Usuários de outros sistemas operacionais podem conseguir acompanhar sem diferenças significativas.
No portal Meridia Verify, dados com picos são indicados pelo perfil de risco para o teste GET07 (Farm plot polygon contains holes).
Importar o polígono para o QGIS
Esta seção fornece uma documentação abrangente para importar arquivos no QGIS para processamento adicional. Esta etapa explica como trazer esses dados para o QGIS, uma popular ferramenta de GIS de código aberto.
Para começar a importar o arquivo, inicie o QGIS pelo menu Iniciar ou ícone da área de trabalho.
No QGIS, para iniciar o processo de importação, vá ao menu Layer > Add Layer > Add Vector Layer (Camada > Adicionar camada > Adicionar camada vetorial)
Uma janela do Gerenciador de Fonte de Dados será aberta. Usando essa janela, os dados são importados para o QGIS. Neste tutorial, os dados a serem importados estão no formato de arquivo KML, que é um dos formatos de dados geoespaciais mais utilizados. Se seus dados estiverem em formatos de arquivo, você também pode seguir essa etapa sem nenhuma etapa adicional ou diferente.
Usando a janela emergente do Gerenciador de Fonte de Dados, os dados podem ser importados.
Selecione o formato original
File(Arquivo).Clique no botão
…para navegar pelo arquivo KML (ou qualquer outro formato de arquivo).
Navegue até sua pasta de dados.
Selecione o(s) arquivo(s) KML para importar.
Clique no botão
Open(Abrir).
Após selecionar os arquivos, clique no botão Add (Adicionar) para finalizar a importação.
A janela do Gerenciador de Fonte de Dados fechará para mostrar o(s) arquivo(s) importado(s) no mapa na janela principal do QGIS no centro, assim como no painel de Camadas no canto inferior esquerdo da janela do QGIS como grupo KML contendo a camada vetorial. No entanto, para outros formatos de arquivo, você pode ver os dados importados como camada única em vez de grupo KML, o que simplifica ainda mais as coisas.
Se o arquivo importado não aparecer no mapa, no painel Camadas, clique com o botão direito no arquivo importado > Aproximar para camada(s) (ou Aproximar para grupo).
Para modificar a visualização do polígono, clique duas vezes na camada Symbology > > Single Symbol > Color (Simbologia > Símbolo padrão > Cor) . Clique OK depois de terminar.
Remover buracos do polígono
Depois que o polígono com buracos é mostrado na visualização principal do mapa QGIS, o próximo passo é ativar o painel QGIS Processing Toolbox, que contém várias ferramentas para necessidades geoespaciais. Para remover buracos da camada de polígonos, será usada a ferramenta chamada "Excluir buracos".
Clique no botão do Painel de Barras de Ferramentas, que mostrará um novo painel chamado Caixa de Ferramentas de Processamento.
Procure pela ferramenta
Delete Holes(Excluir buracos) no painel Caixa de Ferramentas de Processamento.Clique duas vezes na ferramenta
Delete Holespara abrir a janela da ferramenta.
Na janela, o processamento para remover os buracos do polígono pode ser configurado.
Selecione a camada de polígonos a ser processada.
Especifique a área máxima de buracos que serão removidos. Para remover todos os buracos, defina esse parâmetro como 0.
Clique
Run(Executar) para iniciar o processo.
Após a conclusão do processamento, a janela de processamento pode ser fechada. Uma nova camada será mostrada na visualização principal do mapa do QGIS, que é o resultado do processo.
Observe a camada de resultado para garantir que o processo funcione com sucesso conforme especificado.
Exportar o polígono do resultado
Após o resultado estar conforme especificado, ele pode ser exportado para o formato de arquivo preferido.
Clique com o botão direito na camada de resultado >
Export>Save Feature As …(Exportar > Guardar elementos como...)Especifique o formato de arquivo para o resultado a ser armazenado. Neste tutorial, está selecionado
shape file (.SHP)que é o formato de arquivo geoespacial com maior compatibilidade, incluindo compatibilidade com o portal Meridia Verify.Especifique o diretório e o nome do arquivo de resultados. Clique no botão
…à esquerda para navegar pelo diretório preferido.Clique
OKpara finalizar a exportação. Você pode abrir o diretório para encontrar seu arquivo exportado.
Conclusão
Em resumo, remover buracos dos seus polígonos pode ser muito importante para o seu caso, para que seus dados representem a realidade o mais fielmente possível. Usando este tutorial, você terá um polígono sem buracos pronto para ser enviado no portal Meridia Verify.
Incentivamos os usuários a usarem este tutorial para diferentes cenários, para se familiarizarem com o QGIS e com o próprio processo, o que ajudará em outras questões e problemas de engenharia de dados geoespaciais no futuro.
Por favor, consulte os recursos adicionais abaixo para obter mais informações sobre este tutorial.










